使用ElementUI Table报错 ‘querySelector’ of undefined at TableLayout.updateElsHeight

报错的详细信息截图:

错误定位(使用element-ui el-table的属性导致的):

注意解释:
== 我使用的ElementUI中的Table组件中的第一个demo1 在那基础上加了height[ 或者max-height ] 和show-header 这两者一起使用导致报错的 这个还和版本ElementUI有关 这个项目下的版本 “element-ui”: “^2.12.0”,当我们必须两个属性所展示的效果一起使用的的时候怎么办,下面提供了两个解决方法 ==

解决方法1:
使用版本 “element-ui”: “^2.11.1”,在这个版本下height[ 或者max-height ] 和show-header 两者一起用是不会报错的

解决方法2:
不使用show-header属性 用css把头部隐藏起来

注意注意:

我自己测了element-ui为版本 2.11.0和2.12.0 height[ 或者max-height ] 和show-header 两者一起用都会报错 在2.11.1版本下是没有报错的,还是直接改css方便 改版本号到时项目其他地方出错就得不偿失了

原文链接:https://blog.csdn.net/zj25xy11/article/details/103156589

本站教程资源免费提供,扫右侧二维码免费获取》》》》》》》》》》》》》
注:下载本站视频仅供个人学习使用,禁止用于其他用途,因用户自身造成一切问题与本站无关!版权归原作者所有,本站不承担技术及版权问题,如有侵犯您的权益请联系我们删除

为您推荐

发表评论